通达信信号不重复

通达信CCI专家系统怎样过滤重复的卖出信号 买入信号不用过滤

我对照了一下图,感觉你说的意思是想去掉卖出信号,只要买入信号,是这个意思吗?如果是的话
选股公式为:XG:CROSS(CCI(14),-100);

通达信中怎么解决变量的重复赋值问题?

通达信没有循环语句,

但你说这个台阶最高价,不需要循环语句,可以写出来.

用条件跟随函数就可以了 .

VALUEWHEN(REF(HHV(H,BARSCOUNT(C)),1)<H,H);

为什么通达信同一个信号,在不同的版本的软件中显示的效果不同?

不同版本数据不同的情况很多的,即使相同版本在不同的操作系统上选股也不同,你可以试下就知道了
还有一种可能是,你用的指标公式引用了财务数据,比如筹码指标就引用了流通盘,所以其中一个版本的财务数据下载不完整就有可能造成不显示

通达信公式如何用连续数字表示不间断出现的信号数

哎,当年我研究公式都研究着迷了,和楼主似的天天改公式,编写公式,现在对公式已经没有任何兴趣了,这个东东你就设计出来了,也很难完全遵守,而且会因个股、大盘和时间段以及分析周期不同而不同。
其实炒股用不着这么复杂的系统,只需要一个符合你性格的简单重复系统,能长期盈利即可。至于赚打钱得靠运气!

通达信出现买入信号进行选股

VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
X:FILTER((趋势<=13 AND VAR4>13),10);

(已测试)

通达信的选股公式连续几天出现信号,如何编写呢?

不知道你想编什么样的公式,我在此写一个大概的方法吧,你自己结合需要自己修改,比如你要写今天、昨天、前天等3天发出创新高的信号,可以这样写:h>ref(h,1) and ref(h,1)>ref(h,2) and ref(h,3);
解释:h=最高价,ref(h,1)=昨天的最高价,ref(h,2)=前天的最高价,ref(h,n)=n天前的最高价......依此类推,其中的h(最高价)可以替换成其他你需要的指标,比如c(收盘价)
不知道你看明白了么?